re = /'[^=]+=[^']+'/
str = '/\'Team1 = 6\', while /\'Team2 = 4\', and /\'Team3 = 2\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end