package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[A-Z][^\s|]*\s[0-9]+(?:,\d+)?\|)+$`)
var str = `Peter 50|Alex 20,1|
Peter 50|Alex|`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}