use strict;
my $str = 'Peter 50|Alex 20,1|
Peter 50|Alex|';
my $regex = qr`^(?:[A-Z][^\s|]*\s[0-9]+(?:,\d+)?\|)+$`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}