#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[^;]+(?=;[^;]+;$)"
Local $sString = "00.000000 00.000000; X-XX000-0000-0; France; Paris; Street 12a;" & @CRLF & _
"00.000000 00.000000; X-XX000-0000-0; Spain; Barcelona; Street 123;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")