re = /\b[^;]+(?=;[^;]+;$)/m
str = '00.000000 00.000000; X-XX000-0000-0; France; Paris; Street 12a;
00.000000 00.000000; X-XX000-0000-0; Spain; Barcelona; Street 123;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end