import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<option(?!\\sdisabled).*?>(.*?)</option>";
final String string = "<option disabled=\"\" value=\"\">---</option><option value=\"2089974\">Shimano/SRAM HG 10/11-speed</option><option value=\"2089975\">SRAM XDR 11/12s</option>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}