use strict;
my $str = '<option disabled="" value="">---</option><option value="2089974">Shimano/SRAM HG 10/11-speed</option><option value="2089975">SRAM XDR 11/12s</option>';
my $regex = qr/<option(?!\sdisabled).*?>(.*?)</option>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}