use strict;
my $str = 'Ben Meyers (1), Hank Crone (1) (PP)';
my $regex = qr/\s*\((?=[^(]*$)/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";