$re = '/(;){2,}/ui';
$str = '«Hi»
«Hi»;
«Hi»;;
«Hi»;;;
Hi;
Hi;;
Hi;;;
Hi;;;;';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;