re = /(;){2,}/i
str = '«Hi»
«Hi»;
«Hi»;;
«Hi»;;;
Hi;
Hi;;
Hi;;;
Hi;;;;'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result