#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-9]{4})(\/|-)?(0[1-9]|1[012])(\/|-)?(0[1-9]|[12][0-9]|3[01])$"
Local $sString = "13/10/2022" & @CRLF & _
"10/10/2022" & @CRLF & _
"13/10/22" & @CRLF & _
"10/10/22" & @CRLF & _
"13-10-2022" & @CRLF & _
"10-10-2022" & @CRLF & _
"13-10-22" & @CRLF & _
"10-10-22" & @CRLF & _
"131022" & @CRLF & _
"101022" & @CRLF & _
"13102022" & @CRLF & _
"10102022" & @CRLF & _
"20221013" & @CRLF & _
"20221010" & @CRLF & _
"2022-10-13" & @CRLF & _
"2022-10-10" & @CRLF & _
"2022/10/13" & @CRLF & _
"2022/10/10"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")