import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{[^\\}]+\\}";
final String string = "[{\n"
+ "\"customerId\": 906366,\n"
+ "\"subscriberId\": 1231244,\n"
+ "\"realTimeStatusId\": 100,\n"
+ "\"realTimeStatusDate\": \"2017-08-04T09:27:39\"\n"
+ "}, {\n"
+ "\"customerId\": 906235,\n"
+ "\"subscriberId\": 1231244,\n"
+ "\"realTimeStatusId\": 101,\n"
+ "\"realTimeStatusDate\": \"2017-08-04T09:27:39\"\n"
+ "}, {\n"
+ "\"customerId\": 906235,\n"
+ "\"subscriberId\": 1231243,\n"
+ "\"realTimeStatusId\": 100,\n"
+ "\"realTimeStatusDate\": \"2017-08-04T08:27:39\"\n"
+ "}]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}