$re = '/\{[^}]+\}/';
$str = '[{
"customerId": 906366,
"subscriberId": 1231244,
"realTimeStatusId": 100,
"realTimeStatusDate": "2017-08-04T09:27:39"
}, {
"customerId": 906235,
"subscriberId": 1231244,
"realTimeStatusId": 101,
"realTimeStatusDate": "2017-08-04T09:27:39"
}, {
"customerId": 906235,
"subscriberId": 1231243,
"realTimeStatusId": 100,
"realTimeStatusDate": "2017-08-04T08:27:39"
}]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);