$re = '/(https?|ftp):\/\//m';
$str = 'http://www.baidu.com
https://www.baidu.com
ftp://www.baidu.com/a.zip';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);