re = /(https?|ftp):\/\//m
str = 'http://www.baidu.com
https://www.baidu.com
ftp://www.baidu.com/a.zip'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end