$re = '/^(?:<a[^>]*>)([^<]*)/m';
$str = '<a href="link.html"> TITLE </a> <a href="link.html"> SUB TITLE </a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);