re = /^(?:<a[^>]*>)([^<]*)/m
str = '<a href="link.html"> TITLE </a> <a href="link.html"> SUB TITLE </a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end