#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:https?:\/\/)?(?:www\.)?facebook\.com\/(?:(?:\w)*#!\/)?(?:pages\/)?(?:[\w\-]*\/)*?(?:profile.php\?id=(?=\d.*))?([\w\-]*)?(?:[\w\-\.]*)?"
Local $sString = "https://facebook.com/vietphu.nguyen.7?rc=p&refid=52&__tn__=R" & @CRLF & _
"https://facebook.com/shunchina?rc=p&refid=52&__tn__=R" & @CRLF & _
"https://facebook.com/phuocnguyen.nguyen.16568?rc=p&refid=52&__tn__=R" & @CRLF & _
"https://facebook.com/profile.php?id=100004404017311&rc=p&refid=52&__tn__=R"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")