using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:https?:\/\/)?(?:www\.)?facebook\.com\/(?:(?:\w)*#!\/)?(?:pages\/)?(?:[\w\-]*\/)*?(?:profile.php\?id=(?=\d.*))?([\w\-]*)?(?:[\w\-\.]*)?";
string input = @"https://facebook.com/vietphu.nguyen.7?rc=p&refid=52&__tn__=R
https://facebook.com/shunchina?rc=p&refid=52&__tn__=R
https://facebook.com/phuocnguyen.nguyen.16568?rc=p&refid=52&__tn__=R
https://facebook.com/profile.php?id=100004404017311&rc=p&refid=52&__tn__=R";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}