using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^(\n]*) \((\d* Mhz) - (\d* Mhz)\)";
string input = @"A1-A4 US (430 Mhz - 780 Mhz)
A7-A8 PS (420 Mhz - 180 Mhz)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}