$re = '/([^(\n]*) \((\d* Mhz) - (\d* Mhz)\)/m';
$str = 'A1-A4 US (430 Mhz - 780 Mhz)
A7-A8 PS (420 Mhz - 180 Mhz)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);