using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{\n*\s*(\"".*\""\s*:)";
string input = @"{ ""name"": ""Dan"",
""age"": ""38"",
""pippo"": ""12""
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}