package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\d]$|[^\d].$`)
var str = `xyz99
xxxxx
xxx9x
xxxx9`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}