$re = '/[^\d]$|[^\d].$/m';
$str = 'xyz99
xxxxx
xxx9x
xxxx9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);