const regex = /[^a-zA-Z0-9_,\-]([A-z]+)\,[^a-zA-Z0-9_,\-]([A-z]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^a-zA-Z0-9_,\\-]([A-z]+)\\,[^a-zA-Z0-9_,\\-]([A-z]+)', 'g')
const str = `728,"HAY,HAYE",Marie,François,RAUTUREAU,85,29/05/1856,68;`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);