$re = '/[^a-zA-Z0-9_,\-]([A-z]+)\,[^a-zA-Z0-9_,\-]([A-z]+)/';
$str = '728,"HAY,HAYE",Marie,François,RAUTUREAU,85,29/05/1856,68;';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;