const regex = /^(?'asset'02)_(?'market1'\w{3,})\/(?'market2'\w{3,})_(?'type'M)(?'offset'L)_(?'derivative'PHY|FUT) (?'period'M)-(?'year'\d{4})-\b(?'month'0[1-9]|1[0-2])\b$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?\'asset\'02)_(?\'market1\'\\w{3,})\\\/(?\'market2\'\\w{3,})_(?\'type\'M)(?\'offset\'L)_(?\'derivative\'PHY|FUT) (?\'period\'M)-(?\'year\'\\d{4})-\\b(?\'month\'0[1-9]|1[0-2])\\b$', 'gm')
const str = `02_AUT/TTF_H_ML_PHY M-2015-12
02_AUT/TTF_H_ML_PHY M-2016-01
02_GASPOOL_L/GASPOOL_H_ML_PHY M-2015-12
02_GASPOOL_L/GASPOOL_H_ML_PHY M-2016-01`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}