import re
regex = re.compile(r"^(?'asset'02)_(?'market1'\w{3,})\/(?'market2'\w{3,})_(?'type'M)(?'offset'L)_(?'derivative'PHY|FUT) (?'period'M)-(?'year'\d{4})-\b(?'month'0[1-9]|1[0-2])\b$", flags=re.MULTILINE)
test_str = ("02_AUT/TTF_H_ML_PHY M-2015-12\n"
"02_AUT/TTF_H_ML_PHY M-2016-01\n"
"02_GASPOOL_L/GASPOOL_H_ML_PHY M-2015-12\n"
"02_GASPOOL_L/GASPOOL_H_ML_PHY M-2016-01")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")