using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![.?!]\s|“)[A-Z][a-z]+";
string input = @"Alec, Prince, so Genoa and Lucca are now just family estates of the “What”. He said no. He, being the Prince";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}