$re = '/(?<![.?!]\s|“)[A-Z][a-z]+/m';
$str = 'Alec, Prince, so Genoa and Lucca are now just family estates of the “What”. He said no. He, being the Prince';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);