use strict;
my $str = 'Factuur: 2018-4005
Factuur
Nr. 90424571
Factuurnummer: 2019-010
dff factuur : 281319261
factuurnummer: 63
Factuurnummer: 281329164565
Factuur assdg 236373
Factuurnummer 281319265
Factuurnummer 0723 - 1345
Factuur nr. 180262
Factuurnummer : 6322232
';
my $regex = qr/\bfactuur(?:nummer)?.*?(?<=\s)(\d+)(?=\s|$)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}