re = /\bfactuur(?:nummer)?.*?(?<=\s)(\d+)(?=\s|$)/mi
str = 'Factuur: 2018-4005
Factuur
Nr. 90424571
Factuurnummer: 2019-010
dff factuur : 281319261
factuurnummer: 63
Factuurnummer: 281329164565
Factuur assdg 236373
Factuurnummer 281319265
Factuurnummer 0723 - 1345
Factuur nr. 180262
Factuurnummer : 6322232
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end