package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{1,3})([-\s]?\d{3}[-\s]?\d{3})`)
var str = `12377-456-789`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}