$re = '/(\d{1,3})([-\s]?\d{3}[-\s]?\d{3})/m';
$str = '12377-456-789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);