package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{1,6}\s(?:[A-Za-z0-9#]+\s){0,7}(?:[A-Za-z0-9#]+,)\s*(?:[A-Za-z]+\s){0,3}(?:[A-Za-z]+,)\s*[A-Z]{2}\s*\d{5}`)
var str = `751 FAIR OKS AVENUE PASADNA CA`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}