const regex = /\d{1,6}\s(?:[A-Za-z0-9#]+\s){0,7}(?:[A-Za-z0-9#]+,)\s*(?:[A-Za-z]+\s){0,3}(?:[A-Za-z]+,)\s*[A-Z]{2}\s*\d{5}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{1,6}\\s(?:[A-Za-z0-9#]+\\s){0,7}(?:[A-Za-z0-9#]+,)\\s*(?:[A-Za-z]+\\s){0,3}(?:[A-Za-z]+,)\\s*[A-Z]{2}\\s*\\d{5}', 'gm')
const str = `751 FAIR OKS AVENUE PASADNA CA`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}