import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.+?)\\.foo,(?!\\1)(.+?)\\.bar$";
final String string = "x.foo,x.bar\n"
+ "y.foo,y.bar\n"
+ "yy.foo,yy.bar\n\n"
+ "x.foo,y.bar\n"
+ "y.foo,x.bar\n"
+ "yy.foo,x.bar\n"
+ "x.foo,yy.bar\n"
+ "yy.foo,y.bar\n"
+ "y.foo,yy.bar\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}