re = /^(.+?)\.foo,(?!\1)(.+?)\.bar$/m
str = 'x.foo,x.bar
y.foo,y.bar
yy.foo,yy.bar
x.foo,y.bar
y.foo,x.bar
yy.foo,x.bar
x.foo,yy.bar
yy.foo,y.bar
y.foo,yy.bar
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end