package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([\W\w])([^\s]){8,16}$`)
var str = `Asimpl3p@ssword`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}