$re = '/^([\W\w])([^\s]){8,16}$/';
$str = 'Asimpl3p@ssword';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);