$re = '/https\:\/\/www\.bugaboo\.com\/(nl|de|us|gb|es)-.{2}\/(campingbedje|reisebett|travel\-cot|play\-yard|cuna\-de\-viaje)\//m';
$str = 'NL
https://www.bugaboo.com/nl-nl/campingbedje/
https://www.bugaboo.com/nl-en/travel-cot/
DE
https://www.bugaboo.com/de-de/reisebett/
https://www.bugaboo.com/de-en/travel-cot/
US
https://www.bugaboo.com/us-en/play-yard/
https://www.bugaboo.com/us-es/play-yard/
GB
https://www.bugaboo.com/gb-en/travel-cot/
ES
https://www.bugaboo.com/es-es/cuna-de-viaje/
https://www.bugaboo.com/es-en/travel-cot/
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;