const regex = /^[€]\s(1?[5]000|[1-9]{1}[5,0]{1,3}([0]{3,10}))$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[€]\\s(1?[5]000|[1-9]{1}[5,0]{1,3}([0]{3,10}))$', 'mg')
const str = `€ 5000
€ 3000
€ 10000
€ 13000
€ 20000
€ 5000
€ 3000
€ 100000
€ 13000
€ 200000
€ 200000000000
€ 255000
€ 2555000
€ 255000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}