import Foundation
let pattern = #"^[€]\s(1?[5]000|[1-9]{1}[5,0]{1,3}([0]{3,10}))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
€ 5000
€ 3000
€ 10000
€ 13000
€ 20000
€ 5000
€ 3000
€ 100000
€ 13000
€ 200000
€ 200000000000
€ 255000
€ 2555000
€ 255000
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)