$re = '/(?<![a-z])(?=([a-z]+_[a-z]+))/m';
$str = 'ash_tonic_transit_so_kern_err_looo_';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);