re = /(?<![a-z])(?=([a-z]+_[a-z]+))/m
str = 'ash_tonic_transit_so_kern_err_looo_'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end