#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\s*(?:\b[A-Z]{2}\b|\d).*"
Local $sString = "Tortillas Bolsa 2a 1kg 4118" & @CRLF & _
"Tortillinas 50p 1 31Kg TAB TR 46113" & @CRLF & _
"Bollos BK 4in 36p 1635g SL 131" & @CRLF & _
"Super Pan Bco Ajonjoli 680g SP WON 100" & @CRLF & _
"Pan Blanco Bimbo Rendidor 567g BIM 49973" & @CRLF & _
"Gansito ME 5p 250g MTA MLA 49860"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)