import re
regex = re.compile(r"\s*(?:\b[A-Z]{2}\b|\d).*")
test_str = ("Tortillas Bolsa 2a 1kg 4118\n"
"Tortillinas 50p 1 31Kg TAB TR 46113\n"
"Bollos BK 4in 36p 1635g SL 131\n"
"Super Pan Bco Ajonjoli 680g SP WON 100\n"
"Pan Blanco Bimbo Rendidor 567g BIM 49973\n"
"Gansito ME 5p 250g MTA MLA 49860")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)