package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(Rev\.*\s+\D{1,2}|rev\.*\s+\D{1,2}|REV\.*\s+\D{1,2}|rev\.*\s+\D{1,2})`)
var str = `Rev........ %^`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}