import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Rev\\.*\\s+\\D{1,2}|rev\\.*\\s+\\D{1,2}|REV\\.*\\s+\\D{1,2}|rev\\.*\\s+\\D{1,2})";
final String string = "Rev........ %^";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}