# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[(\w+)\](.*)\[\\/\1\]/$2/gm;t' <<< "
[shake2][wave]朝から私の大好きな[scream][big]死[/scream][/big]のにおいがするな...[/wave][/shake2]
[shake2]お前を殺すには骨がおれるが、しかし利益は大きい。ハッハッハ![/shake2]
[shake2]おや、心がおれそうだって?もう全てを放り出してあきらめたらどうだ。キッド[/shake2]
[shake2]そんなに死んでしまうのが好きなら、死とチューしちゃえばいいのに![/shake2]
何か無くなった気がするだって?もし、お前が[icon:camerabadge]カメ ラバッジを持っているなら、撮影ポーズ中に見回して、その[name]何か[/name]を探してみればいい..."